Fórum OpenCart Brasil

Por um e-commerce livre, confiável e profissional

#79847
Olá colegas Opencartianos. :ugeek:

Um problema que tenho visto ocorrer com uma certa frequência, é as lojas OpenCart durante a instalação ou após uma migração de hospedagem, apresentarem a mensagem de erro abaixo:
Warning: htmlentities() charset `UTF-8;' not supported, assuming utf-8

Essa mensagem de erro, informa que a variável do PHP denominada "default_charset", foi preenchida incorretamente, e isso tem acontecido principalmente em hospedagens com cPanel, onde é possível alterar a versão do PHP, sendo que após a alteração da versão do PHP, é que o erro ocorre, pois a variável fica exatamente conforme abaixo:
default_charset = "UTF-8;"

Quando deveria ficar conforme abaixo:
default_charset = UTF-8

Em resumo, corrigindo a linha o problema será resolvido.

Importante:

A linha errada pode está dentro do arquivo php.ini ou .user.ini, ou só poderá ser alterada através do cPanel.
Caso você nunca tenha feito alterações nas configurações do PHP, o ideal é solicitar ajuda ao suporte de sua hospedagem.

Espero que essa dica seja útil. :)
Mudar nome do Destaque

Ótimo que deu certo! Boa sorte e boas vend[…]

Olá, Alguns temas têm idioma configu[…]

Olá, O módulo que desenvolvi exibe […]

Prezados, tudo bem? Gostaria de saber se algu&eacu[…]