Fórum OpenCart Brasil

Por um e-commerce livre, confiável e profissional

Suporte geral sobre problemas técnicos para OpenCart v1.x.
#62223
Estou com este Erro na minha instalação, o site estava ok mas apos mudar de endereço de servidor ocorreu este erro que não estou conseguindo resolver!

Alguém poderia me ajudar? desde já fico grato.
Código: Selecionar todos
Deprecated: mysql_connect(): The mysql extension is deprecated and will be removed in the future: use mysqli or PDO instead in /home/cajumoveis/public_html/loja/system/database/mysql.php on line 6
Warning: session_start(): Cannot send session cookie - headers already sent by (output started at /home/cajumoveis/public_html/loja/system/database/mysql.php:6) in /home/cajumoveis/public_html/loja/system/library/session.php on line 11Warning: session_start(): Cannot send session cache limiter - headers already sent (output started at /home/cajumoveis/public_html/loja/system/database/mysql.php:6) in /home/cajumoveis/public_html/loja/system/library/session.php on line 11Warning: Cannot modify header information - headers already sent by (output started at /home/cajumoveis/public_html/loja/system/database/mysql.php:6) in /home/cajumoveis/public_html/loja/index.php on line 177Warning: Cannot modify header information - headers already sent by (output started at /home/cajumoveis/public_html/loja/system/database/mysql.php:6) in /home/cajumoveis/public_html/loja/system/library/currency.php on line 45

Site com erro: http://www.cajumoveis.com/loja/

Imagem
#62229
Oi amigo, obrigado por está ajudando, :)

Fiz o que vc me indicou mais agora deu isso!,. :shock:

Código: Selecionar todos
Parse error: syntax error, unexpected 'else' (T_ELSE), expecting function (T_FUNCTION) in /home/cajumoveis/public_html/loja/system/database/mysqli.php on line 54
#62240
Valeu amigo, tbm consegui similar no link: http://www.opencarto.com/other/mysqliz- ... pport.html

Também consegui uma informação importante que quero registar para os amigos aqui antes de encerra este tópico!
Eu tinha procurado ajuda também no grupo,. http://www.facebook.com/groups/opencart.brasil.oficial/
O amigo (Denis Gomes Franco ) me informou o seguinte:

___________________________________________________________
A mensagem que aparece não é um erro, é um aviso (WARNING). Por ora a loja vai funcionar funcionando normalmente, e a mensagem é uma instrução para os programadores.

Esta mensagem diz que o comando mysql_connect() deixará de funcionar em uma versão futura do PHP - este é o significado da palavra DEPRECATED, ou seja, ela diz respeito a um comando que deixará de existir.

Isso significa que os programadores devem atualizem seu código de modo a usar outras alternativas para realizar a mesma operação. Porém você está usando a versão 1.5.6.4 do OpenCart, que é um tanto antiga, então você deverá atualizar para uma versão mais recente o mais breve possível pois nas próximas vezes em que sua hospedagem atualizar o PHP a loja pode parar de funcionar de vez.

É possível mudar uma configuração na loja para esconder esses erros e deixar a loja seguir normalmente, mas eu não recomendo fazer isso. É melhor curar a causa do que tratar os sintomas, então planeje-se o quanto antes para atualizar o seu OC.

Lembrando que o OC 2.x, caso opte por migrar para ele, é MUITO diferente do OC 1.5x e fazer a mudança exigirá um bom esforço da sua parte em readaptar módulos e temas. Mas se você está iniciando a loja, recomeçar pode ser mais fácil.
_______________________________________________________
Avatar do usuário
Por reds
Mensagens Especiais Curtidas
#62241
Amigão desculpe não concordar com a descrição,
...o erro esta relacionado diretamente ao conector do banco e scripts desatualizados para este serviço e não com a versão do Opencart em questão, ou seja a instrução DEPRECATED algo como "Obsoleta" diz que a conexão SQL esta obsoleta no uso não que o pacote Opencart esta velho e precisa ser atualizado, por isto instruímos usar MSQLi para resolver o problema, pois nas versões mais recentes do PHP usar PDO ou MSQLi.

Se o servidor esta rodando PHP na versão 5.5 pode haver problemas sim dependendo o template e extensões, porem basta apenas mudar para 5.3 ou 5.4 e tudo de funcionar perfeitamente, porem tudo funciona bem em qualquer versão do PHP, em eu mesmo ja testei em todas e colher o melhor resultado em ambas as versões.
Você pode suprimir todos os erros de outra forma se for o caso, tente escrever isto no arquivo de MSQL.PHP
Imagem

Ao abrir o php insira a linha ---> \system\database ---> msql.php
Código: Selecionar todos
<?php
error_reporting(E_ALL ^ E_DEPRECATED);
:geek:
Moeda não atualiza automaticamente

Sim, foi criado na versão Brasil um novo ti[…]

Ola @Wellington Silvestre Isso é totalm[…]

Orçamento por Produtos

Ola @Alesson de Jesus Isso é totalmente […]

Ola @davlagos Você pode também us[…]