Fórum OpenCart Brasil

Por um e-commerce livre, confiável e profissional

Suporte geral sobre problemas técnicos para OpenCart v1.x.
#79897
Boa noite a todos.
Uso e gosto muito da versão 1.5.2.1 , é bem antiga mas atende com perfeição minhas necessidades. Porém as versões PHP até a 5.2 não serão mais reconhecidas e o site ficará fora do ar se eu não fizer um up na PHP, mas quando fui fazer, consta que o sistema do site 1.5.2.1 não é compatível com PHP's superiores a que eu uso atualmente (PHP 5.2). Não há compatibilidade de fato ou deve estar ocorrendo algo específico ? Se sim, peço ajuda aos nobres colegas sobre o que pode estar ocorrendo.
Desde já o meu muito obrigado a todos.
Cleber
#79898
Olá @WCleber.

A loja funcionou em até que versão do PHP em sua hospedagem?

Algo interessante de se entender, é que o PHP lança novas versões com melhorias e correções de tempos em tempos, e a cada X anos ele descontinua algumas versões, ou seja, este ano vão descontinuar todas as versões 5 do PHP, por isso o ideal é trabalhar com a versão 7 do PHP.

Quando as versões 1.5 do OpenCart foram lançadas, a equipe do OpenCart ainda não tinha a preocupação de manter compatibilidade com as versões futuras do PHP, ou seja, só mantinham a versão compatível com as versões atuais do PHP, e isso é um dos motivos da sua versão não suportar as versões mais atuais do PHP, sendo que nesta época nem tinha o PHP 7. Só começamos a ter essa preocupação de manter compatível a partir das versões 2 do OpenCart, que atualmente é compatível até as versões 7.2 do PHP.

Em resumo, não tem uma receita de bolo para fazer sua loja funcionar com as versões mais atuais do PHP, o que tem que ser feito é colocar a loja em uma versão mais recente e ir concertando os erros que aparecerem na loja, ou seja, caso você não seja programador PHP, o ideal é contratar um freelancer para fazer o serviço.

Espero ter ajudado. :)
reds gostou disso
Aplicativo da loja.

Olá prezados. Sei que o site da loja &eacu[…]

Integração de login

Obrigado pela idéia, acredito que consigo f[…]

Olá, De uns tempos para cá eu fazen[…]

Olá amigos! Haveria possibilidade de confi[…]