Fórum OpenCart Brasil

Por um e-commerce livre, confiável e profissional

Suporte geral sobre problemas técnicos para OpenCart v1.x.
#13912
Olá senhores boa tarde;

Gostaria de saber se alguém poderia me ajudar ou indicar algum lugar aonde eu possa aprender a trazer minha loja para o meu computador e ter ela localmente ou então a instalar o opencart em local host,procurei na net mas não encontrei nada que me ajuda-se tenho o wampserver 2.1 no pc já cheguei a instalar o joomla nele mas não sei como fazer com o opencart,grato desde já.
#14010
Bom dia;
Eu consegui instalar o opencart em localhost e tambem consegui trazer meu site para o modo offline foi so copiar as pastas para o diretorio www do wamp mudar o config.php da pasta raiz e da pasta admim,exportar o db do meu host e depois criar um novo db localmente e importar o arquivo .sql o o painel da administração esta funcionando perfeitamente mas a frente da loja esta toda bagunçada e ao clicar em produtos, categorias e outros links eles não abrem porque o link não esta "http://localhost..." algumas coisa como termos de compra e informações da loja abrem ja as outras paginas não,as imagem tambem não estão abrindo e o slide show não funciona,mas nas pastas esta tudo ok com elas,alguem sabe aonde eu posso ter errado e como posso resolver isso ?
#14014
Elvis Pereira escreveu:Bom dia;
Eu consegui instalar o opencart em localhost e tambem consegui trazer meu site para o modo offline foi so copiar as pastas para o diretorio www do wamp mudar o config.php da pasta raiz e da pasta admim,exportar o db do meu host e depois criar um novo db localmente e importar o arquivo .sql o o painel da administração esta funcionando perfeitamente mas a frente da loja esta toda bagunçada e ao clicar em produtos, categorias e outros links eles não abrem porque o link não esta "http://localhost..." algumas coisa como termos de compra e informações da loja abrem ja as outras paginas não,as imagem tambem não estão abrindo e o slide show não funciona,mas nas pastas esta tudo ok com elas,alguem sabe aonde eu posso ter errado e como posso resolver isso ?
Qual página não abre? Dê um exemplo da URL. Se possível, coloque aqui o conteúdo da sua config.php e admin/config.php entre a tag CODE.
#14018
Renato estou fora do meu pc agora mas posto o config.php mais tarde,quanto as paginas que não abrem bem do painel de administração todas funcionam já da loja apenas as paginas "sobre nós" e a pagina de registro e login funcionam,qualquer outra coisa que eu clique como categorias,produtos,logo da loja etc... não funcionam.
#14025
Elvis Pereira escreveu:Renato estou fora do meu pc agora mas posto o config.php mais tarde,quanto as paginas que não abrem bem do painel de administração todas funcionam já da loja apenas as paginas "sobre nós" e a pagina de registro e login funcionam,qualquer outra coisa que eu clique como categorias,produtos,logo da loja etc... não funcionam.
Para qual endereço o link aponta (oculte o domínio, se for o caso)?? E, pelo amor de Deus, esclareça o que é "não funciona" !!

Dá página não encontrada? Erro 404? Abre a loja (layout) e o erro dentro (Página não encontrada)? ....
#14027
Na imagem abaixo mostra como esta a frente da loja e pra qual link aponta,não funcionam porque não tenho conexão com a internet no outro computador e os links se referem para as paginas da internet não no servidor local então não abre e diz para checar a conexão com a internet e os cabos etc ...
link da imagem: http://bellenus.files.wordpress.com/2012/01/loja.jpg
Como eu faria para ocultar o domínio ?
Aqui esta o config.php
Código: Selecionar todos
<?php
// DIR
define('DIR_APPLICATION', 'C:\wamp\www\segredointimo/catalog/');
define('DIR_SYSTEM', 'C:\wamp\www\segredointimo/system/');
define('DIR_DATABASE', 'C:\wamp\www\segredointimo/system/database/');
define('DIR_LANGUAGE', 'C:\wamp\www\segredointimo/catalog/language/');
define('DIR_TEMPLATE', 'C:\wamp\www\segredointimo/catalog/view/theme/');
define('DIR_CONFIG', 'C:\wamp\www\segredointimo/system/config/');
define('DIR_IMAGE', 'C:\wamp\www\segredointimo/image/');
define('DIR_CACHE', 'C:\wamp\www\segredointimo/system/cache/');
define('DIR_DOWNLOAD', 'C:\wamp\www\segredointimo/download/');
define('DIR_LOGS', 'C:\wamp\www\segredointimo/system/logs/');

// DB
define('DB_DRIVER', 'mysql');
define('DB_HOSTNAME', 'localhost');
define('DB_USERNAME', 'segredoi');
define('DB_PASSWORD', '');
define('DB_DATABASE', 'segredoi_loja');
define('DB_PREFIX', '');
?>
?>
e aqui o admin/config.php
Código: Selecionar todos
<?php
// HTTP
define('HTTP_SERVER', 'http://localhost/segredointimo/admin/');
define('HTTP_CATALOG', 'http://localhost/segredointimo/');
define('HTTP_IMAGE', 'http://localhost/segredointimo/image/');

// HTTPS
define('HTTPS_SERVER', 'http://localhost/segredointimo/admin/');
define('HTTPS_IMAGE', 'http://localhost/segredointimo/image/');

// DIR
define('DIR_APPLICATION', 'C:\wamp\www\segredointimo/admin/');
define('DIR_SYSTEM', 'C:\wamp\www\segredointimo/system/');
define('DIR_DATABASE', 'C:\wamp\www\segredointimo/system/database/');
define('DIR_LANGUAGE', 'C:\wamp\www\segredointimo/admin/language/');
define('DIR_TEMPLATE', 'C:\wamp\www\segredointimo/admin/view/template/');
define('DIR_CONFIG', 'C:\wamp\www\segredointimo/system/config/');
define('DIR_IMAGE', 'C:\wamp\www\segredointimo/image/');
define('DIR_CACHE', 'C:\wamp\www\segredointimo/system/cache/');
define('DIR_DOWNLOAD', 'C:\wamp\www\segredointimo/download/');
define('DIR_LOGS', 'C:\wamp\www\segredointimo/system/logs/');
define('DIR_CATALOG', 'C:\wamp\www\segredointimo/catalog/');

// DB
define('DB_DRIVER', 'mysql');
define('DB_HOSTNAME', 'localhost');
define('DB_USERNAME', 'segredoi');
define('DB_PASSWORD', '');
define('DB_DATABASE', 'segredoi_loja');
define('DB_PREFIX', '');
?>

Boa tarde a todos, Um cliente pediu para tirar a […]

Mudar nome do Destaque

Muito obrigado amigo! Resolveu!

obrigado Manoel, me ajudou muito. Então, o […]

Obrigado pela ajuda, desculpa a demora em responde[…]