Fórum OpenCart Brasil

Por um e-commerce livre, confiável e profissional

Por favor, poste aqui todas as dúvidas que você está tendo sobre a instalação, atualização ou configuração do OpenCart v1.x
#77124
Pessoal, tenho tentado instalar o OC versão 1.5.5.1 em localhost mas sempre quando acesso o intall e aceito os termos fica uma página de erro conforme imagem abaixo:

https://snag.gy/I6YmHJ.jpg

Já tentei utilizando o xampp com versões php 5.4, 5.5 5.6 e até a 7.0. Em ambas situações não consigo instalar esta versão antiga do OC. Fiz um teste e baixei a versão mais atual do OC 3.0.2.0 e mostrou que todos os requisitos foram cumpridos e instalou normalmente, apenas não consigo instalar esta versão antiga do OC.

Preciso instalar esta versão antiga pq tenho uma loja em produção funcionando nesta versão e preciso simular um ambiente de testes em localhost com todo backup desta loja online, se eu só fazer um full backup do servidor de produção e jogar dentro do htdocs do xampp em localhost e reconfigurar os DIR e Acessos db nos arquivos CONFIG ainda assim gera erro.

Alguém que tenha conseguido instalar o OC 1.5.5.1 em localhost para poder passar mais informações detalhadas sobre como configurou o XAMPP?

*Estou utilizando MAC.
#77133
Nunca tive esse tipo de erro por isso não tenho muitas informações, mais é bem provável que seja devido a conexão com o banco de dados, aconselho pegar o arquivo system/database/mysqli.php da versão 1.5.6.4 do opencart e enviar para system/database de sua loja, após isso edite o arquivo config.php modificando a linha define('DB_DRIVER', 'mysql'); para define('DB_DRIVER', 'mysqli');, se não for isso não tenho ideia do que pode ser; Boa sorte;
#77180
veteranodf escreveu:
09 Fev 2018, 23:21
Nunca tive esse tipo de erro por isso não tenho muitas informações, mais é bem provável que seja devido a conexão com o banco de dados, aconselho pegar o arquivo system/database/mysqli.php da versão 1.5.6.4 do opencart e enviar para system/database de sua loja, após isso edite o arquivo config.php modificando a linha define('DB_DRIVER', 'mysql'); para define('DB_DRIVER', 'mysqli');, se não for isso não tenho ideia do que pode ser; Boa sorte;
OK amigo, obrigado pela tentativa de ajuda, vou testar isto amanhã e retorno o resultado. Boa noite.
#77183
herman.monteiro escreveu:
14 Fev 2018, 22:21
veteranodf escreveu:
09 Fev 2018, 23:21
Nunca tive esse tipo de erro por isso não tenho muitas informações, mais é bem provável que seja devido a conexão com o banco de dados, aconselho pegar o arquivo system/database/mysqli.php da versão 1.5.6.4 do opencart e enviar para system/database de sua loja, após isso edite o arquivo config.php modificando a linha define('DB_DRIVER', 'mysql'); para define('DB_DRIVER', 'mysqli');, se não for isso não tenho ideia do que pode ser; Boa sorte;
OK amigo, obrigado pela tentativa de ajuda, vou testar isto amanhã e retorno o resultado. Boa noite.
Não deu certo do jeito que você falou, mas consegui resolver criando as pastas cache e logs dentro de System e também adicionando permissão completa para user_mysql no diretório raiz, acontece que clonei o projeto de um repositório e a pessoa que criou não tinha incluído estas pastas que citei.
Desde já agradeço pela tentativa de ajuda.

Manoel Vidal, Bom Dia! deu certo, após c[…]

Ola @Fábio Design segue abaixo o footer,[…]

Rastreamento [Resolvido]

companheiros, não consegui acertar nema pri[…]

Como Atualizar o tema?

Ola @Luciano Barbosa Você poderia ler a […]