Fórum OpenCart Brasil

Por um e-commerce livre, confiável e profissional

Por periscuelo
Mensagens
#57712
Com esta modificação instalada todas as URLs amigáveis serão geradas de forma
automática a partir do titulo ou nome do produto, dessa forma você não precisa mais
escrever as URLs amigáveis manualmente na administração do opencart ou usar um
módulo para essa finalidade, pois a modificação automatiza a escrita para você.

Também preenche automaticamente o Meta Título dos Produtos.

Essa modificação funciona para os produtos, categorias, fabricantes e pagina de
informações.

Para instalar basta fazer o upload do arquivo zip no instalador =)

O Script foi baseado na versão para 1.5.x - Auto URL VQMod 1.0 16/10/2012 Criado por AngelinDark
Vide http://www.opencart.com/.....&extension_id=8779

download

Espero que ajude a todos :D
Editado pela última vez por periscuelo em 10 Nov 2016, 09:16, em um total de 2 vezes.
#57796
Periscuelo, vou botar aqui a conversa lá do OC sobre esse seu módulo, e o que está acontecendo comigo, para ver se de repente, sou eu que estou errando em alguma coisa, ok?
Robson Carimbos escreveu:Até um certo ponto ele funciona, mas quando se vai clicar em um link de um produto, aparece depois da URL amigável algo assim: -p49c28c29.html e não carrega nada
periscuelo escreveu:@RobsonOlegario: Juro que não entendi seu comentário. A unica coisa que esta modificação faz é colocar automaticamente o preenchimento de alguns campos quando se cadastra um produto. Se na sua URL amigável, dentro da administração, não tem nenhum -p49c28c29.html escrito no campo, como o módulo deixou de funcionar???
Robson Carimbos escreveu:@periscuelo: Mas é exatamente isso que está acontecendo. Segui o tutorial do OC Brasil, tudo ok. Fiz as alterações dos departamentos, e etc.. Mas os links dos produtos está assim: http://www.robsoncarimbos.com.br/pt-br/ ... 20c26.html
Robson Carimbos escreveu:@periscuelo: A URL amigável está ativada. Pode conferir lá no meu site como fica os links, e não abre nenhum.
Por periscuelo
Mensagens
#57831
Robson, ainda não entendi.
Quando você preenche o nome do produto por exemplo, o que ele grava / mostra lá no campo de url amigável da administração?
#57833
periscuelo escreveu:Robson, ainda não entendi.
Quando você preenche o nome do produto por exemplo, o que ele grava / mostra lá no campo de url amigável da administração?
Nome do Produto: Colop Printer C 10 Azul
URL amigável: colop-printer-c-10-azul
Mas no site o link desse produto fica assim: "http://www.robsoncarimbos.com.br/pt-br/ ... 20c26.html" (Sem as aspas) quando ativo a URL amigável.
Por periscuelo
Mensagens
#57834
Então @Robson, a única coisa que a modificação faz é ajudar no cadastro das URL's amigáveis no admin.
Se no admin está certo a modificação está funcionando, pois ela nada tem a ver com o link que é mostrado
na loja ou com o erro que está ocorrendo. Ela simplesmente faz com que você não tenha que digitar a URL
manualmente, mais nada. Se no banco de dados está tudo certo, consegue entender então que o erro não está
na administração do opencart que é o único lugar onde a modificação atua?
#57845
periscuelo escreveu:Então @Robson, a única coisa que a modificação faz é ajudar no cadastro das URL's amigáveis no admin.
Se no admin está certo a modificação está funcionando, pois ela nada tem a ver com o link que é mostrado
na loja ou com o erro que está ocorrendo. Ela simplesmente faz com que você não tenha que digitar a URL
manualmente, mais nada. Se no banco de dados está tudo certo, consegue entender então que o erro não está
na administração do opencart que é o único lugar onde a modificação atua?
Ok. Mas então aonde está o erro? Realmente, seu módulo faz o que diz: Cria a URL amigável corretamente, mas qual seria a causa desse link estranho, que acaba não abrindo nada? Fiz como diz o tutorial do OC Brasil (Como meu servidor é Linux (Hostgator) e não criei nenhuma pasta para instalar o OC, então não mexi no arquivo .htaccess), fui nos departamentos e subdepartamentos, fiz as URLs amigáveis, mas nada adiantou...
Por veteranodf
Mensagens Especiais Curtidas
#57850
Primeiramente cheque se a url amigável esta habilitada na admin da loja, depois disso verifique se tem um arquivo ".htaccess" no diretório raiz da loja, não é "htaccess.txt", se for esse tem que renomear para o que informei, feito isso se o seu servidor estiver configurado corretamente as url amigável vão funcionar, desde que você tenha preenchido no produto, categorias, etc, se não funciona você deve solicitar o seu serviço de hospedagem para habilitar a biblioteca "mod_rewrite";
#57851
veteranodf escreveu:Primeiramente cheque se a url amigável esta habilitada na admin da loja, depois disso verifique se tem um arquivo ".htaccess" no diretório raiz da loja, não é "htaccess.txt", se for esse tem que renomear para o que informei, feito isso se o seu servidor estiver configurado corretamente as url amigável vão funcionar, desde que você tenha preenchido no produto, categorias, etc, se não funciona você deve solicitar o seu serviço de hospedagem para habilitar a biblioteca "mod_rewrite";
Tudo isso já está feito. O arquivo ".htacces" existe sim, tanto que tive de alterá-lo para ativar o php 5.3 e fazer o OC 2.0.1.1 funcionar. Só não tenho certeza do "mod_rewrite".
Por periscuelo
Mensagens
#57888
@Robson, infelizmente neste quesito não vou conseguir lhe ajudar. :|
Tente as dicas do @veteranodf, quem sabe ajude.
Só peço por gentileza que abra outro tópico pois este é para problemas na modificação,
que não é o seu caso.

Espero que consiga resolver seu problema.

Abraços.
Atributos pré definidos

Obrigado @reds , mas no caso é que j&aa[…]

[Resolvido] Melhorar o campo de busca

Olá @rlasmar . Já fiz uma corre[…]

Uhuuuu, muito obrigada pelo retorno vou pesquisar […]

Como ser parceiro

Pessoal, sou novo por aqui, estou integrando o ope[…]