Fórum OpenCart Brasil

Por um e-commerce livre, confiável e profissional

Suporte geral sobre problemas técnicos para OpenCart v3.x.
#86613
Ola @cjfranca

Aparentemente você não indicou as variáveis no controller para os textos indicados no erro,
Reveja o controller do seu modulo e indique as variáveis com os respectivos textos em seu arquivo de tradução.
Isso é válido para versões ate 2.3x, para versões de 3x acima basta setar a variável no arquivo de linguagem do seu modulo e/ou de onde você setou para carregar os textos.

No controller
Código: Selecionar todos
$data['minha_variavel'] = $this->language->get('minha_variavel');
No arquivo de linguagem
Código: Selecionar todos
$_['minha_variavel']          = 'Aqui esta minha variavel';
#86628
@reds obrigada pela atenção e orientação, mas verifiquei que no arquivos .tpl não há essas linhas do mesmo modo que dentro da pasta controller tam catalog e admin, só há outras subpastas ( devo estar entendendo algo errado). Eu preciso de mais alguma referencia para localizar o erro, exite algo a mais que possa mencionar para eu conseguir resolver.
#86629
cjfranca escreveu:
23 Jan 2020, 01:09
@reds obrigada pela atenção e orientação, mas verifiquei que no arquivos .tpl não há essas linhas do mesmo modo que dentro da pasta controller tam catalog e admin, só há outras subpastas ( devo estar entendendo algo errado). Eu preciso de mais alguma referencia para localizar o erro, exite algo a mais que possa mencionar para eu conseguir resolver.
É necessário alterar o arquivo
Código: Selecionar todos
admin/language/en-gb/extension/module/productcolorbasedimages.php
(ou similar).

Caso o erro continue, acesse o arquivo
Código: Selecionar todos
admin/controller/extension/module/productcolorbasedimages.php
(ou similar) e, antes da linha
Código: Selecionar todos
$this->response->setOutput
, adicione o código abaixo:
Código: Selecionar todos
$data['text_main_img_no_change'] = $this->language->get('text_main_img_no_change')
Erro após a instalação

.

Erro no segundo domínio

Boa dia! Fiz a instalação de dois s[…]

Olá, recentemente tive problemas com meu s&[…]

Olá a todos ! Tenho um sistema com muitos p[…]