Fórum OpenCart Brasil

Por um e-commerce livre, confiável e profissional

Suporte geral sobre problemas técnicos para OpenCart v3.x.
Avatar do usuário
Por reds
Mensagens Especiais
#88815
Boa tarde pessoal,

Alguém que disponível que pegaria o JOB para fazer uma modificação no arquivo do Tiny para que ele suporte o pedido abaixo?

"
Nós analisamos seu caso junto ao nosso time técnico e hoje os parâmetros utilizados no arquivo do tiny.api.php estão otimizados para serem trabalhados com produtos sem opções (variações) que neste caso não é o formato que você utiliza.

Para obter os dados página por página, o Tiny faz a busca e realiza a leitura de todos os itens a cada página, montando em uma lista e contando todos os produtos que possuem em seu site inclusive as suas variações, pois cada variação também é um item. O fato de ter mais de 13000 produtos afeta a leitura destes produtos, pois para página o Tiny vai realizar a leitura e o seu servidor acaba não suportando essa consulta e o erro então é retornado.
Diante deste fato, uma das opções é você verificar com seu programados a possibilidade de alteração nos filtros parametrizados no arquivo tiny.api.php para que sejam importados produtos com alguma distinção, para que assim consiga diminuir a carga de consulta dos seus dados.
Afirmamos que essa é uma alteração que deve ser realizada exclusivamente pela sua loja, pois não alteramos essas parametrizações no arquivo.

Infelizmente não há outro meio de se contornar o problema ao não ser como foi repassado acima, ou se realiza um filtro nas buscas para cada nova busca limitar essa consulta, ou a importação por planilhas também é uma opção.
"
Por smfsoft
#89910
Olá @reds , estou tentando integrar o Tiny ERP com uma site opencart 3. Mas não está conectando. Você conseguiu fazer a conexão lá nas configurações do Tiny? Eu suspeito que algo com a versão no arquivo da api do tiny. Mas não sei o que deveria ser modificado. é uma vergonha o suporte deles, dizer pra eu procurar uma adaptação, sendo que eles mesmos é que fornecem o arquivo de integração dizendo que é compativel com a loja na versao 3.
Avatar do usuário
Por reds
Mensagens Especiais
#89913
Ola @smfsoft

Sim nos conectamos, precisa de ajuda?
;)

@Eltlas Matos tem esse link com erro parecido c[…]

sitemap com categorias

acredito que só tem módulo pago. :sh[…]

As pastas que criei no gerenciador de azrquivos do[…]

Ola @mickabalah Envie um email para: suporte@a[…]