Fórum OpenCart Brasil

Por um e-commerce livre, confiável e profissional

Suporte geral sobre problemas técnicos para OpenCart v1.x.
#90209
Olá pessoal, tudo bem? Ao fazer update da versão 1.5.6 para a 1.5.6.1 apareceu o seguinte erro:

Fatal error: Class 'DBmysqliz' not found in xxx/loja/system/library/db.php on line 13

verifiquei que os arquivos dp.php são diferentes entre as duas versões:

db.php Versão 1.5.6 (funciona)
Código: Selecionar todos
<?php
class DB {
	private $driver;
	
	public function __construct($driver, $hostname, $username, $password, $database) {
		if (file_exists(DIR_DATABASE . $driver . '.php')) {
			require_once(DIR_DATABASE . $driver . '.php');
		} else {
			exit('Error: Could not load database file ' . $driver . '!');
		}
				
		$this->driver = new $driver($hostname, $username, $password, $database);
	}
		
  	public function query($sql) {
		return $this->driver->query($sql);
  	}
	
	public function escape($value) {
		return $this->driver->escape($value);
	}
	
  	public function countAffected() {
		return $this->driver->countAffected();
  	}

  	public function getLastId() {
		return $this->driver->getLastId();
  	}	
}
?>

db.php Versão 1.5.6.1 (não funciona)
Código: Selecionar todos
<?php
class DB {
	private $driver;

	public function __construct($driver, $hostname, $username, $password, $database) {
		$file = DIR_DATABASE . $driver . '.php';

		if (file_exists($file)) {
			require_once($file);

			$class = 'DB' . $driver;

			$this->driver = new $class($hostname, $username, $password, $database);
		} else {
			exit('Error: Could not load database driver type ' . $driver . '!');
		}
	}

	public function query($sql) {
		return $this->driver->query($sql);
	}

	public function escape($value) {
		return $this->driver->escape($value);
	}

	public function countAffected() {
		return $this->driver->countAffected();
	}

	public function getLastId() {
		return $this->driver->getLastId();
	}
}
?>

Notei que, nas versões 1.5.6.2 e 1.5.6.4, o arquivo db.php está com o mesmo conteúdo do arquivo da versão 1.5.6.1

O que será que está errado na configuração atual da loja? Como poderia corrigir o problema para dar andamento nas atualizações?

obrigado a todos.
#90211
Olá @Plastic Kits.

A mensagem de erro informa que o OpenCart 1.5 não está localizando o arquivo abaixo:
system/database/mysqliz.php

Neste caso, este é o arquivo de drive para conexão com o banco de dados da loja.

Você pode editar os dois arquivos config.php e modificar o valor da constante "DB_DRIVER" de "mysqliz" para "mysqli".

Assim o problema será resolvido.

Espero ter ajudado. :D
Plastic Kits gostou disso

Ola @quegaroto Não entendi corretamente[…]

Boa tarde. Após a cópia do backup, […]

Backup sem imagem do produto

Boa tarde, @rlasmar Agradeço a mensage[…]

Sugestão de servidor

Ola @CaioLima Consulte aqui os planos: Planos […]