Fórum OpenCart Brasil

Por um e-commerce livre, confiável e profissional

Suporte geral sobre problemas técnicos para OpenCart v3.x.
Avatar do usuário
Por marciojosebaldo
#90555
Bom dia

Aqui mesmo no fórum, encontrei uma recomendação para backup das imagens do OpenCart que é copiar as 2 pastas abaixo do site principal:
/admin/view/javascript/jquery/flot/examples
/image/

E fazer o backup do banco de dados. Essa parte deu certo com o phpMyAdmin. Contudo, as imagens não aparecem nos produtos, mesmo após ter copiado as 2 pastas acima

Há algo que passou despercebido?
#90557
@rlasmar , obrigado pela dica

Conferi o /admin/config.php/ e alterei a linha:
define('DIR_CATALOG', '/var/www/html/image/catalog/');

Acrescentei o /image/ que é o local certo da pasta catalog. A config.php raiz não tem o caminho storage. E ambos config.php estão corretos a IMAGE:
define('DIR_IMAGE', '/var/www/html/image/');

O Apache foi reiniciado e mesmo assim continua o mesmo problema
#90559
O OC foi reinstalado novamente

O banco de dados está sendo incorporado tranquilamente pelo phpMyAdmin e a descrição e título estão adequados. Apenas o preço que sai neste código: 99decimal_point00

Contudo, a pasta localhost/image/catalog, mesmo copiada, não aparece nos anúncios do localhost. Dentro do banco de dados, está correto o diretório. Um exemplo: catalog/Produtos/Informatica/Monitor/1. Tela/TFT/1...

Há algum detalhe passando despercebido
Avatar do usuário
Por quegaroto
Mensagens
#90560
Olá @marciojosebaldo

O detalhe deve ser somente o config.php e no admin/config.php

Geralmente no plano de hospedagem os endereços das pastas começam com /home/xxxx/xxx/..... ou /home1/xxx/xxx/... ou /home3/xxx/xxxx .... talvez esta faltando você colocar a pasta (diretório) raiz (root).

Já vi casos também que se o SSL não tiver funcionando no seu domínio as imagens não abrem.
Outro caso é o GD não presente no PHP. (isso o suporte da hospedagem pode verificar para você).

Abraço.
marciojosebaldo gostou disso
#90561
Bom dia, @quegaroto.

Obrigado pela resposta.

Checado os config.php, ambos estão corretos e iguais entre VPS e localhost. Acredito que o problema de home1, home2 e etc deva ser corriqueiro em servidores com base no Windows. Ao menos, com o Linux e usando a KingHost, isso não aconteceu até agora.

Interessante você apontar o SSL. Realmente, no VPS parou de funcionar e no localost não tem. Acredito que deva ser o foco para tentar resgatar as imagens.

O GD também foi conferido. Já estava instalado, atualizado e é um requisito para instalação do OC. Foi um outro ótimo ponto de vista seu. Se eventual desatualização, não funcionaria no backup.
#90565
marciojosebaldo escreveu:@rlasmar , obrigado pela dica

Conferi o /admin/config.php/ e alterei a linha:
define('DIR_CATALOG', '/var/www/html/image/catalog/');

Acrescentei o /image/ que é o local certo da pasta catalog. A config.php raiz não tem o caminho storage. E ambos config.php estão corretos a IMAGE:
define('DIR_IMAGE', '/var/www/html/image/');

O Apache foi reiniciado e mesmo assim continua o mesmo problema
Ta errado seu config.php

No admin/config.php deve ser conforme abaixo

define('DIR_IMAGE', '/var/www/html/image/');
define('DIR_CATALOG', '/var/www/html/catalog/');

E é necessário também ter o caminho do STORAGE nos dois arquivos config.php
#90572
Boa tarde, @rlasmar

Agradeço a mensagem. Os dois config.php copiados do servidor estão corretos. Aquele diretório acima foi deixado na tentativa de entrar na hipótese anterior. Para conseguir fazer o backup é necessário deixar do jeito que está

Deu certo, pessoal. Problema resolvido! O tutorial acima está correto e foi dado pelo Matheus aqui mesmo no forum: viewtopic.php?t=1413

Aqui não dava certo porque no Linux, precisa permitir a edição das pastas. Sem essa permissão, o OpenCart não consegue ler os arquivos. Era apenas este detalhe que passava despercebido. No Linux, para quem usa, permita com o 755. No Windows, não faço ideia de como liberar essas edições ou se é que existam. A distribuição foi no Ubuntu 20.04 e Linux Mint 20.3

Agradeço ao suporte de todos vocês. Se formos nos ajudando e também relatar como foi resolvido o problema, seremos cada vez uma comunidade mais forte. É parte do aprendizado uma maior dependência minha no começo, mas darei futuramente minhas contribuições ao fórum por ter mais experiência na plataforma.
Backup sem imagem do produto

Boa tarde, @rlasmar Agradeço a mensage[…]

Sugestão de servidor

Ola @CaioLima Consulte aqui os planos: Planos […]

Integração Opencart com Bling

Boa noite Srs. surgiu uma situação a[…]

alarme falso.. Voltou... apenas as ja tradiconais […]