Fórum OpenCart Brasil

Por um e-commerce livre, confiável e profissional

Suporte geral sobre problemas técnicos para OpenCart v3.x.
Por fabio.zech
#86752
Pessoal, estou tendo dificuldades com a ativação das url amigáveis, fiz a inclusão dos nomes amigáveis nos meu produtos, e segui as orientações aqui do site de como ativar https://www.opencartbrasil.com.br/tutor ... -amigaveis mas ao ativar ele apresenta erro 404, e desabilita o https na loja, a configuração do meu htaccess esta assim pois o pessoal da hospedagem configurou para ativar o https e as configurações do opencart deixei comentado para que a loja funcionasse enquanto isso, não entendo muito de htaccess alguém poderias me ajudar?
Código: Selecionar todos
RewriteEngine On
RewriteCond %{HTTPS} off
RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI}

# Ativar url Amigável

#RewriteBase /
#RewriteRule ^sitemap.xml$ index.php?route=extension/feed/google_sitemap [L]
#RewriteRule ^googlebase.xml$ index.php?route=extension/feed/google_base [L]
#RewriteRule ^system/storage/(.*) index.php?route=error/not_found [L]
#RewriteCond {REQUEST_FILENAME} !-f
#RewriteCond {REQUEST_FILENAME} !-d
#RewriteCond {REQUEST_URI} !.*\.(ico|gif|jpg|jpeg|png|js|css)
#RewriteRule ^([^?]*) index.php?_route_=$1 [L,QSA]
Avatar do usuário
Por quegaroto
#86755
Olá @fabio.zech

Tente mudar o seu .htaccess tirando os # das linhas #Rewrite... ficaria assim: Rewrite...

E atualize.
Por fabio.zech
#86762
Se eu tirar os # e ativar dentro da loja ele da o problema do conflito que comentei na pergunta, por isso esta com o # estou procurando uma solução que funcione.
Alguém poderia me ajudar, lembrando que a parte do codigo que o opencart precisa funcionar com a parte de cima que o pessoal da hospedagem configurou, mas se eu tirar o # e simplesmente ativar, alem de desativar o https ele ainda da erro 404

Alguém teria alguma sugestão?
Avatar do usuário
Por reds
Mensagens Especiais Curtidas
#86768
Ola @fabio.zech
Reponha o arquivo original do Opencart (HTACCESS)e tente habilitar as URLs amigáveis, caso mesmo assim obtenha erro, entre em contato com sua hospedagem notificando sobre o retorno inesperado.
:)

fabio.zech escreveu:Se eu tirar os # e ativar dentro da loja ele da o problema do conflito que comentei na pergunta, por isso esta com o # estou procurando uma solução que funcione.
Alguém poderia me ajudar, lembrando que a parte do codigo que o opencart precisa funcionar com a parte de cima que o pessoal da hospedagem configurou, mas se eu tirar o # e simplesmente ativar, alem de desativar o https ele ainda da erro 404

Alguém teria alguma sugestão?
quegaroto gostou disso
Por fabio.zech
#86771
Legal, fiz isso eles alteraram mas o dominio ficou assim https://ateliecrisramos.com.br/index.ph ... tica-creme

Ficou esse index.php?_route_= no meio e eles colocaram que é algo da plataforma que eles não podem alterar, alguem tem alguma ideia de como retirar essa parte, o htaccess ficou assim:
Código: Selecionar todos
Options +FollowSymlinks

# Prevent Directoy listing
Options -Indexes

# Prevent Direct Access to files
<FilesMatch "(?i)((\.tpl|.twig|\.ini|\.log|(?<!robots)\.txt))">
 Require all denied
## For apache 2.2 and older, replace "Require all denied" with these two lines :
# Order deny,allow
# Deny from all
</FilesMatch>

# SEO URL Settings
RewriteEngine On
# If your opencart installation does not run on the main web folder make sure you folder it does run in ie. / becomes /shop/

RewriteBase /
RewriteRule ^sitemap.xml$ index.php?route=extension/feed/google_sitemap [L]
RewriteRule ^googlebase.xml$ index.php?route=extension/feed/google_base [L]
RewriteRule ^system/storage/(.*) index.php?route=error/not_found [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_URI} !.*\.(ico|gif|jpg|jpeg|png|js|css)
RewriteRule ^([^?]*) index.php?_route_=$1 [L,QSA] 


RewriteEngine On
RewriteCond %{HTTPS} off
RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI}
#86926
Pessoal bom dia.

Estou com o mesmo problema aqui.
Fiz a inclusão dos nomes amigáveis nos meu produtos, e segui as orientações aqui do site e quando ativo as urls amigáveis e clico em qualquer produto ele vai para erro 404.
Não entendo muito de htaccess, alguém poderias me ajudar? Já fiz a alteração para .htacesses e nada.
O meu htacesses está assim, bem diferente dos que eu vi aqui:

# php -- BEGIN cPanel-generated handler, do not edit
# Set the “ea-php72” package as the default “PHP” programming language.
<IfModule mime_module>
AddType application/x-httpd-ea-php72 .php .php7 .phtml
</IfModule>
# php -- END cPanel-generated handler, do not edit
<FilesMatch "\.(ttf|ttc|otf|eot|woff)$">
<IfModule mod_headers.c>
Header set Access-Control-Allow-Origin "*"
</IfModule>
</FilesMatch>

Agradeço a atenção e ajuda.
Avatar do usuário
Por reds
Mensagens Especiais Curtidas
#86930
MarcosCamargo escreveu:Pessoal bom dia.

Estou com o mesmo problema aqui.
Fiz a inclusão dos nomes amigáveis nos meu produtos, e segui as orientações aqui do site e quando ativo as urls amigáveis e clico em qualquer produto ele vai para erro 404.
Não entendo muito de htaccess, alguém poderias me ajudar? Já fiz a alteração para .htacesses e nada.
O meu htacesses está assim, bem diferente dos que eu vi aqui:

# php -- BEGIN cPanel-generated handler, do not edit
# Set the “ea-php72” package as the default “PHP” programming language.
<IfModule mime_module>
AddType application/x-httpd-ea-php72 .php .php7 .phtml
</IfModule>
# php -- END cPanel-generated handler, do not edit
<FilesMatch "\.(ttf|ttc|otf|eot|woff)$">
<IfModule mod_headers.c>
Header set Access-Control-Allow-Origin "*"
</IfModule>
</FilesMatch>

Agradeço a atenção e ajuda.

Adicione o arquivo original que veio na instalação da versão do seu Opencart e adicione esses linhas ao final do mesmo.
Lembrando que deve renomear o arquivo htaccess.txt para .htaccess

Nesse seu arquivo ele diz apenas sobre qual versão do PHP a ser usada e permitir pacotes de fontes sem problemas.
:D
quegaroto, MarcosCamargo gostou disso

Olá @Andrei Teixeira Veja se esse t&oacu[…]

Erro ao solicitar cálculo do frete

Na finalização da compra ao colocar […]

Tem algo errado. Por padrão ele já […]

Vc vai buscar somente a primeira linha, no caso &l[…]